Jump to content
Sign in to follow this  
AnkH

RESOLVED Annoying full screen flickering

Recommended Posts

Hi all,

I took the plunge and got myself a copy of EF. So far, only using automation mode with a PTA preset. Looks very nice, another addition to better and more realistic flying in the sim. However, I noticed that after firing up P3Dv4.5, the screen flickers a lot. When looking around in the VC, not in the outside view. It seems to me as if EF needs to "get started", flickering mess. It seems like the whole screen turns black for a microsecond, it is not really something inside the engine that flickers (clouds, textures, reflections), rather the full screen. Then, after some minutes, it seems to get settled and the flickering gets less and less, until it is only occasional for the rest of the flight. However, it does not entirely disappear and that makes it pretty annoying. Is this something the devs are aware? Might it be related to some nVIDIA driver setting? What can I do about this?

Without EF, the flickering is not there. Also it does not make a difference if I use the PTA shaders as a basis or the P3D default shaders. As soon as EF is active, the flickering occurs with extreme flickering at the beginning of the flight.

I use a 1080Ti with the most current driver, running the sim on 1440p with 4xSSAA and rather high settings. In addition, I use ActiveSky as weather engine and REX SF for the cloud textures etc. No setting in the nVIDIA control panel except "prefer maximum performance", no nVIDIA Profile Inspector setting. All I use is the opaque and translucent shadow fix in the prepar3d.cfg as well as an AM setting.

As a monitor, I use a DELL S2716DG with G-sync, which I disabled for P3D. Refresh rate is set on 120Hz.

Thanks for any hint...

Regards

Chris

Share this post


Link to post
Share on other sites
23 minutes ago, AnkH said:

I noticed that after firing up P3Dv4.5, the screen flickers a lot.

This is not related to EF! You forgot to turn off "Full screen optimisations" within the compatibility options (right click on P3D icon).

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

I did indeed. Strange enough, that the flickering only occurs when I use EF though. But thanks for the heads up, I might have forgotten this "trick" the last time I installed P3D (or updated it). Will see if this fixes it.

Share this post


Link to post
Share on other sites

Check the texture definition both in SF and in EF.

Default in EF is 4096 which could create this flickering.

Gérard

 

Share this post


Link to post
Share on other sites

"Full screen optimizations" it was. Thanks for the quick help, case closed.

  • Like 2

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • See our many awards!

×
×
  • Create New...