Jump to content
NTN

RESOLVED Performance/Low FPS issue

Recommended Posts

I am experiencing a significant FPS drop while using Environment Force. It was from day one and hotfix for EF and TU for SkyForce as also P3D v4.5 Hotfix did not change anything. Technically P3D 4.5 Hotfix made small FPS improvements, like about 3-5 FPS, but FPS is dropping from 60 to 10, so it is insignificant.

I am using EF + SF3D the latest updates on P3D v4.5 with Hotfix. I tried to reinstall P3D Client and EF, it does not make any changes.

It is for both Manual and Auto mode!

I tried default simple and complex airports, I have ORBX, but airports are defaults from P3D.

On the simple scenery:

P3D only:                                 60+ FPS

P3D + SF3D:                           50+ FPS

P3D + SF3D + EF Manual:  ~10  FPS

P3D + SF3D + EF Auto:       ~10 FPS

On the complex scenery:

P3D only:                                 30+ FPS

P3D + SF3D:                           30+ FPS

P3D + SF3D + EF Manual:  ~18  FPS

P3D + SF3D + EF Auto:       ~18 FPS

I am using VR, so 30 FPS is a minimum or it is unusable. So at current state EF is unusable.

Attaching screenshots for all cases in the same order:

Simple scenery:

P3D Only:

2019-5-14_22-36-48-386.thumb.jpg.49534e2bb8a73315f3c880110cb62299.jpg

P3D + SF3D:

2019-5-14_22-52-13-582.thumb.jpg.a6df14cb85426a51f2d24fd29f43ca9e.jpg

P3D + SF3D + EF Manual:

2019-5-14_23-2-6-966.thumb.jpg.b8414a7b6643a5647b04c9440af04914.jpg

P3D + SF3D + EF Auto:

2019-5-14_23-7-5-531.thumb.jpg.fee373c569d33f4e920d32595f83fa43.jpg

Complex scenery:

P3D only:

2019-5-14_23-13-3-276.thumb.jpg.75291793e18192ccb63e75b960568fd4.jpg

P3D + SF3D:

2019-5-14_23-22-21-449.thumb.jpg.cdf882ea44e4eb78c5394a015dce3b15.jpg

P3D + SF3D + EF Manual:

2019-5-14_23-31-43-927.thumb.jpg.7ccd5e817f6a182499050bbdcf6f462b.jpg

P3D + SF3D + EF Auto:

2019-5-14_23-38-12-639.thumb.jpg.3058a56db011b1872187b4af5f7347c4.jpg

Share this post


Link to post
Share on other sites

What are your cloud texture sizes set to in EnvironmentForce and SkyForce?

Share this post


Link to post
Share on other sites
27 minutes ago, paj said:

What are your cloud texture sizes set to in EnvironmentForce and SkyForce?

I am using max settings:

Cloud: 4096 + DXT5

Cirrus: 2048 + DXT5

Share this post


Link to post
Share on other sites
3 hours ago, NTN said:

I am using max settings:

Cloud: 4096 + DXT5

Cirrus: 2048 + DXT5

With a CPU running at only 3Ghz, I would think it may have a problem at 4096. I would try backing down to see if your frame rates don't improve.

Share this post


Link to post
Share on other sites
4 minutes ago, gets said:

With a CPU running at only 3Ghz, I would think it may have a problem at 4096. I would try backing down to see if your frame rates don't improve.

I do not have any issue running SF3D with 4096, I do not see how should I expect any issues with using EF with the same settings? And my i7-5960X is an "Extreme Edition" running up to 3.5Ghz and is utilizing less than 20% of usage overall and per core when I am running P3D. I do not expect hardware is a bottleneck here, but I will try when I get back to my sim.

Share this post


Link to post
Share on other sites
35 minutes ago, NTN said:

but I will try when I get back to my sim.

Yes, please give 512 a quick test for both clouds types and see if there is a significant difference.

There was for me (i7-7700K @ 5GHz 1080TI)

Share this post


Link to post
Share on other sites

Gentlemen, re-install EF.  So I solve the problem.

Share this post


Link to post
Share on other sites
6 hours ago, paj said:

Yes, please give 512 a quick test for both clouds types and see if there is a significant difference.

There was for me (i7-7700K @ 5GHz 1080TI)

Tried to set to 512 everything: P3D texture, SF3D texture, and EF texture. Even reinstalled EF for the second time. I quickly OC my CPU to 3.8Ghz. The results are the same:

P3D only:                              70 FPS

P3D + SF3D + EF Auto:      16 FPS

P3D + SF3D + EF Manual: 16 FPS

P3D only:

2019-5-16_22-4-30-574.thumb.jpg.ca2dd01ebf71644d74ae914cbe960f86.jpg

P3D + SF3D + EF Auto: 

2019-5-16_22-8-36-994.thumb.jpg.205b4468b2e963ced469970ed511a9eb.jpg

P3D + SF3D + EF Manual:

2019-5-16_22-32-50-574.thumb.jpg.d53065057f66825bbb4df14c8585383a.jpg

  • Thanks 1

Share this post


Link to post
Share on other sites

Are you using SF weather engine?

Share this post


Link to post
Share on other sites

I can not reproduce this issue Using SkyForce3D+EF+Active Sky

Can you try to turn of HDR just for a test. This kills my FPS

Share this post


Link to post
Share on other sites
5 hours ago, Nyxx said:

Are you using SF weather engine?

Yes

5 hours ago, fresH229 said:

I can not reproduce this issue Using SkyForce3D+EF+Active Sky

Can you try to turn of HDR just for a test. This kills my FPS

I will try this. I do not think that HDR or other settings are culprits here as everything working fine without EF.

Share this post


Link to post
Share on other sites
Posted (edited)

Same issue today, started and got 8-16 frames (just p3d 4.5 HF1 + EF 1.1.2). Standart scenario in the F-22. HDR off in EF UI did not change a thing. Uninstalled SF and EF and now frames are back to normal. I will try to replicate that.

Windows 10 professional
Installed addons:
AS4
ASCA
EF + SF
ORBX
A2A GA aircrafts

Edited by Rasterfahnder

Share this post


Link to post
Share on other sites
Posted (edited)

Yes,

 

I regret installing the latest fix; my frames are in the gutter. I usually got 40 frames, now I get 8. I do not believe hardware is a factor in this case.

 

And if you ask... 2990WX @4.25Ghz all cores |  2080TI Sli | DDR4 64GB ECC @ 2667 | Chilled water, temps are in the low 30s...

Edited by IncreaseVS

Share this post


Link to post
Share on other sites
2 minutes ago, IncreaseVS said:

Yes,

 

I regret installing the latest fix; my frames are in the gutter. I usually got 40 frames, now I get 8. I do not believe hardware is a factor in this case.

 

And if you ask... 2990WX @4.25Ghz all cores |  2080TI Sli | DDR4 64GB ECC @ 2667 | Chilled water, temps are in the low 30s...

You got this frames with EF+SF+AS or how?

How is the FPS if you manually delte all Shaders and Disable the REX Dll to load the sim without REX?

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, fresH229 said:

You got this frames with EF+SF+AS or how?

How is the FPS if you manually delte all Shaders and Disable the REX Dll to load the sim without REX?

 

Apologies for not including more details. 

AS + ASCA (Redundant) +  EF 1.1.2

---

I'll test it and mention you when I do.

 

@fresH229

EDIT Ok, I have done this and it works when you start Environment Force after your scenario has loaded. The performance hit is noticeable but less

 

I have varying results when I try to do so. The bug is still there in the majority. 

---

 

Edited by IncreaseVS

Share this post


Link to post
Share on other sites

All of a sudden I have this problem too with AS+EF. 15 FPS max. If I don't start EF, I have 40-60 FPS.

Strange thing is that I flew in the morning and FPS were fine. The weather was also almost the same as it is now. Is it afternoon problem? 🤣

Share this post


Link to post
Share on other sites

So what's the plan here. Should we uninstall it for now and wait for a hot fix? Cause this is not flyable now.

Share this post


Link to post
Share on other sites
Posted (edited)

I Had the same problem where I was down to 10fps at a default airport right after installing EF latest technical update. Things you can try that resolved my problem:

*Clear Shaders

*Uninstall/reinstall P3dv4.5 CLIENT

What really resolved my problem are these settings:

Please back up P3d.cfg first before trying. If this fails to work, you can try rebuilding you P3d.cfg by deleting it and restarting P3d.

[DISPLAY]
TEXTURE_BANDWIDTH_MULT=160            
[SCENERY]
MaxRegionsPurgePerFrame=1

[TERRAIN]
UseGlobalTerrainView=True
TEXTURE_SIZE_EXP=9

[MAIN]
FIBER_FRAME_TIME_FRACTION=0.15

[GRAPHICS]
ENABLE_MEMORY_OPTIMIZATION=0

MAX_TEXTURE_REQUEST_DISTANCE=320000.000000


[SCENERY]
SCENERY_DRAW_DISTANCE=64000.000000

Edited by teeroy66

Share this post


Link to post
Share on other sites

Sorry..I made a booboo:

Should Be, Uninstall/reinstall P3dv4.5 CLIENT, NOT Content

Share this post


Link to post
Share on other sites
On 5/17/2019 at 6:09 AM, fresH229 said:

I can not reproduce this issue Using SkyForce3D+EF+Active Sky

Can you try to turn of HDR just for a test. This kills my FPS

Turned HDR off - did not make any changes, literally the same FPS numbers

Installed the latest EF Update - did not make any changes

But I accidentally found it while playing with configs: "Enable Dense Cirrus Overcast Layer" on "Cirrus Cloud Control"

When it is on - I have FPS loss, when it is off - almost 0 FPS loss and everything is fine! When you re-install EF it is off by default, that how it might help somebody. But I confirmed for me: 4096 text resolution, HDR on, SF as WX, EF - both Auto and Manual mode is ok if "Enable Dense Cirrus Overcast Layer" is off, and having FPS drop if it is on.

  • Thanks 1

Share this post


Link to post
Share on other sites

I really hope "Enable Dense Cirrus Overcast Layer" on "Cirrus Cloud Control" to off will solve my low fps as well. I run 3 monitors in surround and I cannot use EF at all. Will find out soon. 

Share this post


Link to post
Share on other sites
2 hours ago, speedbird144 said:

I really hope "Enable Dense Cirrus Overcast Layer" on "Cirrus Cloud Control" to off will solve my low fps as well. I run 3 monitors in surround and I cannot use EF at all. Will find out soon. 

 

9 hours ago, NTN said:

Turned HDR off - did not make any changes, literally the same FPS numbers

Installed the latest EF Update - did not make any changes

But I accidentally found it while playing with configs: "Enable Dense Cirrus Overcast Layer" on "Cirrus Cloud Control"

When it is on - I have FPS loss, when it is off - almost 0 FPS loss and everything is fine! When you re-install EF it is off by default, that how it might help somebody. But I confirmed for me: 4096 text resolution, HDR on, SF as WX, EF - both Auto and Manual mode is ok if "Enable Dense Cirrus Overcast Layer" is off, and having FPS drop if it is on.

Hello,

 

Thanks for your information! I tried to disable that function and restarted my computer, the frame-rates increase by 5-10 in rainy weather but ultimately remains unplayable. This thread deserves more attention and is game breaking...

 

Perhaps the developer could post a history of releases so we can revert to the ones that work for our systems the best?

 

Regards,

Share this post


Link to post
Share on other sites

So what should we do now? Wait for a quick hot fix? I'm not flying now, cause i'm waiting for some solutions. 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • See our many awards!

×
×
  • Create New...