Jump to content
Deltaair12

RESOLVED REX SF crash

Recommended Posts

I am getting these crashes whenever SF is running in the background with the latest build installed in v4.3. It happens after the sim finishes loading the senario but the screen stays black then just crashes. My computer logged one of the crashes and it’s a .dll issue. 

Share this post


Link to post
Share on other sites

Try deleting your shader folder and letting it rebuild, especially if you recently updated video drivers. I get a dxgi error whenever I update drivers and forget to delete that folder. If that doesn't work, you can try reverting back to a previous build on drivers. That has worked for me in the recent past. 

Share this post


Link to post
Share on other sites
1 hour ago, wain said:

have you added any other items to the sim? there could be a clash...did it say what dll was responsible?

Api.dll. And I recently deleted windows and rebuilt my OS. So everything is fresh if you will. 

Share this post


Link to post
Share on other sites

I am experiencing this as well. I have done extensive diagnosis on this and it really comes down to REXSF. When it is running P3DV4 just does CTD after a while. When it not running everything is fine. It appears to be worse with the new 411 drivers for my GTX 1080Ti. I have gone back to an older version but still the same. Will try the shader deletion now.

Shez

Edited by sheza

Share this post


Link to post
Share on other sites

I confirm the problem is not delete shader related. Experimentation shows the crash occurs only if SF is left on in the background. Maybe there is some update issue.

Shez

Share this post


Link to post
Share on other sites

More: For the REX team this appears to have become a problem for us after the latest round of Windows 10 updates.

Shez

Share this post


Link to post
Share on other sites
1 hour ago, sheza said:

More: For the REX team this appears to have become a problem for us after the latest round of Windows 10 updates.

Shez

I am getting a crash even if SF isn’t running in the background. Can you confirm this? Thanks

Share this post


Link to post
Share on other sites
32 minutes ago, REX Support said:

Hi there,

Which .dll is at fault here? Can you post a screenshot of the crash you are receiving?

Wellllll now I’m not so sure REX SF is the cause of all of this. Because my sim is crashing right after the load screen is finished downloading the senario with or without SF running in the background. And it’s not logging the crashes either. The last crash it logged was on the 24th. Since then I’ve had at least 10-15 CTD’s. 

2DC077BA-6185-424E-9F7D-EA393E6B97D7.jpeg

Share this post


Link to post
Share on other sites

This is what I am experiencing as well. Nothing comes up on appcrashview but the common factor always is SF. Without SF all is well.

Shez

Share this post


Link to post
Share on other sites
Just now, sheza said:

This is what I am experiencing as well. Nothing comes up on appcrashview but the common factor always is SF. Without SF all is well.

Shez

We’re not having the same issues then. My sim crashes even without SF in the background and yours crashes only if SF is running in the background if I understand correctly 

Share this post


Link to post
Share on other sites

UPDATE: When I got home today I mentally prepared myself to sit at my computer and not budge (except for bathroom breaks) until I sniff out the cause of my CTD. I uninstalled every add-on again, and then uninstalled P3D, and deleted all Lockheed content on my C drive and cleaned the slate. I made sure all computer settings were in a normal state, and no background apps were running in task manager. I downloaded P3Dv4.3 fresh and kept the settings the way they were after the fresh install. I did not move a slider an inch. Next I started with UTL. I did three start ups and loads with the default flight and UTL. No CTD. Next I moved on to AS16. I did three loads as well. No CTD. Afterwards was KTNP. Still no CTD after three loads. But then I installed Accu-Feelv2. The first load was fine. The SECOND load I got a CTD. Hmm. So then I uninstalled the app, and did ten (yes ten) loads without Accu-Feel. No CTD. I then enabled the app again, and did 10 more loads. No CTD. So I’m theory, my CTD was after I installed Accu-Feel. But I couldn’t replicate the issue after the first crash. I will keep testing, but I have my eye on Accu-Feel. It would make sense because the app was just made available to P3Dv4, so I wouldn’t be surprised if they’re still working out bugs...

Share this post


Link to post
Share on other sites

I’ve had the api.dll issue in the past, but that was fixed with a running a repair of Content of P3D. Since you did a complete reinstall, that may have fixed the issue but not sure. Is that accurate-feel v4.3 compatible? I know this is a dumb question, but are you running P3D as admin? It’s weird there is an “access violation” as the error. Maybe has something to do with the UAC?

Share this post


Link to post
Share on other sites

Hi Delta,

Based on the message you posted I think you are on the right track; the crash didn't appear to be SF related. Keep us posted on how it goes.

Share this post


Link to post
Share on other sites
10 minutes ago, REX Support said:

Hi Delta,

Based on the message you posted I think you are on the right track; the crash didn't appear to be SF related. Keep us posted on how it goes.

Hi REX team. It is in fact Accu -Feel causing these crashes. Whenever I have the app inabled in P3D I get frequent CTD’s. When it is disabled I get no crashes. I have contacted the A2A team and I’m waiting on a response. Thank you 

Edited by Deltaair12

Share this post


Link to post
Share on other sites

Well mine is definitely REX SF related. It is the only program which causes it. My workaround is to launch it, let it update environment, then close it. Then do it again closer to destination. Go ahead and close it but it is an issue.

Shez

Share this post


Link to post
Share on other sites
6 minutes ago, REX Support said:

Sounds good. If you are all right with it, I will close this ticket out?

Yes that is fine, thanks 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • See our many awards!

×
×
  • Create New...