Jump to content

Recommended Posts

This is happening to me now. IIRC it's only been happening the last month or so, but I haven't been simming a whole lot.

" Stop running this script?" Yes/No

"A script on this page is causing your web browser to run slowly. If it continues to run your computer might become unresponsive".

It was suggested in this thread to update IE but no one ever reported whether that actually did anything or not.

http://www.realenvir...__fromsearch__1

One thing perhaps different in my case (it seems there may be some relation) is that I've always had the REX notification sounds checked to OFF, but I've always gotten the little beep. Also, for whatever it's worth, lately I seem to get a lot of sluggish behavior withn FS itself, esp. near airports.

Anyhoo, I thought I'd ask before futzing with an IE update, or in case the additional info matters at all. Thx.

Share this post


Link to post
Share on other sites

Ah heck. I forgot to mention my FSX has hardlocked twice out of ~ the last 5-7 times up.

Share this post


Link to post
Share on other sites

What version of Internet Explorer are you using?

Share this post


Link to post
Share on other sites

The issue is resolved with upgrading to IE 9 or IE 10. The reason is because we are using mapping scripts that utilize more modern javascript engines. IE 8 does not accommodate those more advanced scripts.

Share this post


Link to post
Share on other sites

Yeah, I've been using Firefox since it was Phoenix.

Thanks for all the effort thus far.

Share this post


Link to post
Share on other sites

To fix this you need to upgrade to IE 9 or 10. Also, we will be issuing a new mapping system with the next SP update. This may help.

Share this post


Link to post
Share on other sites

Well Steve I'm in the same boat as you, but I have Win7 64 bit. I had a problem with FSX just refusing to boot with fatal error at the initial startup screen. Thought it was the nVidia driver, but later conclusively ruled it out to be IE. I think I'm using IE8 now because installing IE 9 or IE 10 kills FSX with fatal error on startup and also kills my Firefox and Rise of Flight. I suppose a commonality is that all affected applications are DirectX based. Can't use Firefox at all, won't boot. So I uninstalled IE 9 and IE 10 updates and boom everything works perfectly, just still get the script runs slowly error and I just live with it. However, I shall try this fix until I get more research as to why IE 9 and 10 are killing my computer.

Share this post


Link to post
Share on other sites

Getting off the path of this thread a bit, and sorry for being fuzzy but I believe I read something in another forum that suggests trying two things:

1. Try reinstalling DirectX - my guess is that you'll do this and get an "everything's okay!" Message though.

2. The other is to make sure you have latest redistributables for Microsoft Visual C Runtime (MSVC) for MSVC 2005 and 2008.

I believe this info is laid out in a thread in the MS FSX sub forum on Avsim.net. The thread is subject-headed "ActiveX" problem by Shermann, it sounds similar to what you describe [an IE script filtering problem]. Hope that helps! But yes, such intricacies in the interaction of end-of-life software in a newer OS environment can become increasingly thorny over time. It's kind of unavoidable. MS's going wild with every possible security concept under the sun doesn't help matters. You'll know the hackers have won when you go to boot up your PC one morning and get the message, "I'm sorry but due to security risks, I can't do anything. Retry? Wait? I'm out of ideas."

Edited by FleetingThought

Share this post


Link to post
Share on other sites

Steve-o you were right, I tried the interim registry fix last night and no script errors. I'll try re-DirectX ing it and also checking up on Visual C runtimes later and see if it'll play niceynice with IE 10.

Share this post


Link to post
Share on other sites

Glad to have helped!

I also discovered yesterday that my .NET 3.5SP1 was still slightly damaged (errors and warnings in Event Viewer/.NET Framework Optimization Service); since (finally) having figured out how to repair that (search for .NET Framework repair tool on MS site), things seem to be running more smoothly (better FPS).

I learned while hunting that .NET includes realtime garbage collection in RAM, as well as periodic RAM defragmentation (called compaction in this case), so it's possible those two processes weren't running or finishing correctly on my system, causing performance degradation but no explicit error messages.

Always good to make sure (via Event Viewer) that your .NET is okay, is my new OCD mantra.

Edited by FleetingThought

Share this post


Link to post
Share on other sites

Always good to make sure (via Event Viewer) that your .NET is okay, is my new OCD mantra.

Lol! Good point Steve :)

Share this post


Link to post
Share on other sites

I'm going to try the reg hack. Did you both use the DWORD hex value that shut it down completely, or did you enter some value < the default 5mil?

I opened Event Viewer but couldn't find the .NET stuff.

Share this post


Link to post
Share on other sites

If you don't have a .NET report it probably means it's fine, I only got an item in my application list when there was an error.

I just shut the error message down completely in the DWORD with 0xFFFFFFF Hex or whatever the article recommended. :)

I still don't know whether the "slow running of the script" is still happening, probably, and don't know whether it affects performance, and how much.

FSX is freaky; this morning I tried a familiar flight and got my Lancair Legacy broken into that funny mix of model pieces FSX will create when you've overloaded the graphics card, spikes, etc. Exited FSX, restarted it, reset settings to lower than ever, same problem. Rebooted this evening, started up, same flight plan (my neurotic test route from 2S1/Vashon around Seattle and into KSEA, to make things blow up....), REX running, flew through an exciting thunderstorm with full sound effects, lightning flashes and 2048 HD clouds (this on an ancient Core2Duo 6600 at 2.4GHz, mind you!), and it went fine, no OOM, no CTD, a few moments of stutters is all.

Who knows?!

My gauges went out, but that's because I forgot to turn on my pitot heat in a thunderstorm. :) Engine started to lose RPM, too. It was an adventure!

Share this post


Link to post
Share on other sites

@FleetingThought - Please email me with the link you had for the .net fix tool. I have another person, that I think has this issue.

Share this post


Link to post
Share on other sites

Hi RS,

Email sent -- link for both the .NET Framework repair tool, and for how to turn off the IE8 script error popup by adding a DWORD to the registry.

Best,

Steve

Share this post


Link to post
Share on other sites

Steve, wow, thank you once again!

JZL, did this work for you?

Share this post


Link to post
Share on other sites

Thank you Steve!!! I will review it when I get home from my business trip from Oklahoma.

Share this post


Link to post
Share on other sites

Hi RS,

Email sent -- link for both the .NET Framework repair tool, and for how to turn off the IE8 script error popup by adding a DWORD to the registry.

Best,

Steve

Looks like the reg tweak fixed it-- thanks, everyone!

Share this post


Link to post
Share on other sites

Excellent! Thank you for reporting back.

Thanks to you as well Steve!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • See our many awards!

×
×
  • Create New...