Jump to content
Suavec

RESOLVED REX reports no internet while using proxy

Recommended Posts

I have recently upgraded to REX Essential + Overdrive for P3D and now I can't get any real weather updates while using proxy.

Previous version (REX Overdrive for FSX) worked fine with proxy while IE was configured to use it.

Obviously something has changed how REX Essential handles internet connection.

Would that be possible for REX to detect proxy? or maybe is there some setting in config file?

I would appreciate if this works over proxy as most of my simming time I have to use proxy for internet access.

Slawek

Share this post


Link to post
Share on other sites

So just to clarify you were using REX 2 + Overdrive and it worked fine, now you are using REX Essential Plus Overdrive and it isn't working now? Please give us more details about your proxy setup? Also, when you say "you cant get any real weather updates" are you referring initially when REX starts or in game?

Share this post


Link to post
Share on other sites

Yes, that is correct - previously it was REX 2 + Overdrive.

It was working with present proxy setup and wouldn't matter if I run REX interface or just WX engine (automatically started up with FSX).

My proxy settings are quite simple it is just an IP and port number entered in Internet Explorer (Internet Options, Connections, LAN Settings).

Usually all applications auto-detect proxy settings from IE.

Current REX Essential Plus Overdrive was able to connect to internet and download weather while I was connected to WiFi. Now when I have no choice but using proxy, REX reports no internet connection and when I click on Weather tab, option Use Real-Weather Data is greyed out. I can choose only random or archived data but when I click Fly Now, I get a window "No Internet Detected: REX must have access to an active internet connection to operate the weather engine. Please connect to an active internet connection and restart REX."

The windows appears with no delay - I mean, there are no indications of REX trying to connect and timing out.

I use Kaspersky Internet Security 2013 as anti-virus and firewall but it is not a problem in this case.

Also I was thinking how REX knows there is no internet connection if it is not even trying to connect?

I don't know if this has something to do but while using proxy, the Network Interface icon in tray has yellow triangle with exclamation mark and indicates No Internet Connection status. This is normal while using proxy but maybe somehow REX reads this status from Windows?

However I tried disabling this notification (using command netsh winhttp set proxy) but still the same...

Slawek

Share this post


Link to post
Share on other sites

REX utilizes port 80 to download data from our web services provided by our data servers. So something is blocking that connection. Check your antivirus software and make sure REX has exclusion rights.

Share this post


Link to post
Share on other sites

Port 80 works fine through my proxy as it is standard http port. My antyvirus is not blocking it or REX.

The question is if REX recognises proxy settings from IE as it was in version 2 or if not, is there a way to add proxy settings?

When does REX checkes for internet connection - only during startup (splash screen)?

Share this post


Link to post
Share on other sites

I am sorry for the delayed response, but I was trying to see if I could find a solution for you. Unfortunately, but this is beyond our normal operations of REX. REX accesses its data via web services using port 80. So this should not be an issue.

I wish I could offer you more service, but I can't.

I will post your topic on our beta team forum to see if anyone there may have a solution.

Thank you for your patience.

Share this post


Link to post
Share on other sites

I just had a chance to use plain WiFi (without proxy) and my REX worked fine. Then I moved back (with REX still on) to my wired connection with proxy and after setting up IE with proxy settings, Weather Engine was working over proxy.

As I see, WX Engine uses windows/ie libraries to connect to internet, therefore it accepts proxy settings from IE.

Unfortunately REX is doing some checks during startup and when internet is not discovered then it prevents WX Engine to be launched. That's when you see REXNONINTERNET as your Product Key in ABOUT section.

I was trying to use some 3rd party software to capture traffic at port 80 to proxy but it seems that initial check for internet and Product Key is done differently - maybe over https?

Is there anyway to overide no internet state to force launching WX engine? REX v2 had separate program and it was also possible to auto-start it with FSX.

BTW: No, I don't use 2Wire modem.

Share this post


Link to post
Share on other sites

The code at the beginning that determines if there is any internet connection is not any different than the other code. So that is not the issue. I guess my question is if it works fine the one way why not use it the normal way. Why are you using a proxy?

Share this post


Link to post
Share on other sites

I'm working offshore and using VSAT during my off-work time. All internet traffic goes through proxy as per my company policy. Currently we are in port - that's why I got WiFi for a while.

That's why it is so important for me to have REX working over proxy - as it was with v2.

Edited by Suavec

Share this post


Link to post
Share on other sites

I am just checking in to see if the issue you are experiencing has been resolved?

Share this post


Link to post
Share on other sites

No. REX still doesn't work while using proxy, doesn't recognize proxy as valid internet connection, prevents WX engine from launching even if this works over proxy and make it impossible to use historical weather data.

If downgrading to 2.5 (which was working fine over proxy), is it possible to use old version with P3D?

Share this post


Link to post
Share on other sites

Technically it is not licensed to be used with P3D. We will look into this, but why not just use REX in a normal setup?

Share this post


Link to post
Share on other sites

This issue has been closed by the administrator.

Share this post


Link to post
Share on other sites

Can we mark this issue resolved or closed?

Share this post


Link to post
Share on other sites

We have not heard back from you in a while, so we are going to mark this issue resolved. If you need further assistance please feel free to open a new topic.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • See our many awards!

×
×
  • Create New...